Access 2007-2019
Access 2000-2003
Access Seminars
TechHelp Support
Tips & Tricks
Access Forum
Course Index
Topic Glossary
Insider Circle
 
Home   News   Courses   Tips   Templates   Forums   Help   Order   Contact   Logon  
 
 
Microsoft Access Forum

Forums > Access

Welcome to the Microsoft Access Forum. Access is by far our most popular topic here at Computer Learning Zone. This forum is for everyone to read but only students (paid customers) can post here. If you'd like to become a student, you can watch Access Beginner Level 1 for free, and then purchase Level 2 for just $1.00 here. After you create a logon, you will have full access to the Forums.

Subscribe to this forum and receive an email update whenever new posts are added. You will also be notified by email if any conversations you are involved in receieve new comments. Yes, even non-students can subscribe to update notifications.

Click Here to Post a comment and start a new discussion!

Upcoming Projects Link 
Richard Rost     
Today 2:47 pm
Here's what's coming up soon...

ACCESS DEVELOPER 14 - EASY ACCESS POS

I'm continuing to work on Access Developer 14 today. I was hoping to release the next lesson last week, but I had an emergency problem on the web site that took me 3 days to fix and set me back. In any case, look for that soon. If you're interested in joining the class as we build the POS system, here's a link: Access Developer 14 Read More...
Add a Reply
Get Rid of Tabs Link 
Shawn Hicks   
Mon 7/6
I created a database for our Animal Control.  Everything was working fine until I changed up my form and started using tabs.  In the owner and animal tabs, I have a drop down where user I can select the owner and animal, and then it populates the fields within the tab.  It worked fine until I moved the fields to the tabs.  Now they won't populate.  Is there another code I should use, instead of "ME", when working within tabs?
Richard Rost    
Mon 7/6
I really hate tabs. Can't stand them. I even say so in my Beginner and Expert classes numerous times: DON'T USE TABS! Why? When you start getting into more advanced stuff, like you're finding out, they become a nightmare to work with. I'd rather have multiple smaller forms, or have to scroll, than to use tabs. But, generally, if you drop a field, let's say FieldA in a tab, then it should behave like the rest of the controls on the form. Should. But sometimes it doesn't. Good luck! What's your code that does the populating?
Shawn Hicks  
Mon 7/6
I must have missed that.  I was considering going back to just the form.  Here's the code for owner and animal:
Private Sub OwnerID_Change()
Me.LastName.Value = Me.OwnerID.Column(1)
Me.FirstName.Value = Me.OwnerID.Column(2)
Me.Address.Value = Me.OwnerID.Column(3)
Me.City.Value = Me.OwnerID.Column(4)
Me.State.Value = Me.OwnerID.Column(5)
Me.Zip.Value = Me.OwnerID.Column(6)
Me.Phone.Value = Me.OwnerID.Column(7)

End Sub

Private Sub AnimalID_Change()
Me.AnimalType.Value = Me.AnimalID.Column(1)
Me.OtherType.Value = Me.AnimalID.Column(2)
Me.PrimaryBreed.Value = Me.AnimalID.Column(3)
Me.SecondaryBreed.Value = Me.AnimalID.Column(4)
Me.PrimaryColor.Value = Me.AnimalID.Column(5)
Me.SecondaryColor.Value = Me.AnimalID.Column(6)
Me.Sex.Value = Me.AnimalID.Column(7)
Me.SpayNeut.Value = Me.AnimalID.Column(8)
Me.AniName.Value = Me.AnimalID.Column(9)
Me.DateofBirth.Value = Me.AnimalID.Column(10)
Me.Age.Value = Me.AnimalID.Column(11)

End Sub
Add a Reply
Splitting Names Link 
Shelagh Fagan     
Mon 7/6
My issue is about a default value in a table. I have a lastname,firstname field that I need to split. I have the RIGHT/LEFT/INTRS coe strings and I have used them sucessfully in a form. They enter lastname,firstname and the first name & last name appear in their boxes on the form totally correctly. But I realized that I really need to do this in the ARTIST TABLE. The combined field is called FullNameSQ. So I put in the relevant field  the exact expressions I used for the form fields & it says "can't find FullNameSQ". So I tried [T_Artist]![FullNameSQ]. Doesn't like this either. Why doesn't this work? Its an existing field in the table. When we enter a new record ( either directly or via the form) I want the First Name and Last Name fields to populate automatically. Then I don't need the expressions on the form.
Richard Rost    
Mon 7/6
So you're able to successfully split a FullName field into FirstName and LastName using form text boxes? OK. Now just create FirstName and LastName fields and bind text boxes to the appropriate fields.
Add a Reply
Append Query copying data twice Link 
Jim Byers    
Fri 7/3
O.K. I've got another one I don't understand.

I've set up a query to transpose or append relevant information to a NewCustomerT table from the existing CustomerT table.
I've set this up on the originating table/form to send the data to the new table/form rather than calling for it from the new table/form. Not sure if that is relevant. Read More...
Jim Byers   
Sat 7/4
Bear with me, I'm just experimenting
Richard Rost    
Sun 7/5
Hi Jim. First, you can't embed any images or links in posts in my Forums. I disabled any links or tags for security reasons. I had one customer who thought he was being cute - posted an image embedded from his web site for me to look at (like you did) and then after the conversation was over he changed the image to something inappropriate. So, since then I don't allow images. I'm working on a way you can upload images to my site to be included in your posts, but that's a feature I haven't implemented yet.
Add a Reply
Control Wizard on Subform Link 
Thomas Corbett    
Wed 7/1
My control Wizard is not working in the design controls. I am not trying to use it on a sub-form and the "Use Control Wizards" is chosen. Any solutions?
Richard Rost    
Thu 7/2
You can't use the control wizards on SUBFORMS. You have to open the form up by itself. Limitation of Access. I never knew this myself either (because I don't use the wizards unless I'm teaching them). But after a little research, it appears this is the case. I just learned something too!
Thomas Corbett   
Thu 7/2
I am not using it on Sub-Forms. I even started a new database and brought everything in and it still didn't work :(
Add a Reply

Show Older Posts

 

Post Your Comments
 
Only students may post right now. Click here for more information on how you can set up an account. If you are a student, please LOG ON first.
 
Subscribe
 

You may want to read these articles from the 599CD News:

7/6/2020Access Mailing Label Seminar
7/6/2020Access Mailing Label Template
6/30/2020Access Seminars
6/29/2020Access Create Duplicate Record
6/28/2020Access Times as a Duration
6/25/2020Access D14 Lessons 2, 3 Ready
6/20/2020Microsoft Access Developer 14
6/17/2020Access Time 12 hour NO am/pm
6/16/2020Access Handbook News
6/16/2020Access Developer 7 Handbook
 

Learn
 
Access - index
Excel - index
Word - index
Windows - index
PowerPoint - index
Photoshop - index
Visual Basic - index
ASP - index
Seminars
More...
Customers
 
Account Login
Online Theater
Downloads
Lost Password
Free Upgrades
Insider Circle
Student Databases
Change Email
Info
 
Latest News
New Releases
User Forums
Topic Glossary
Tips & Tricks
Articles
Search The Site
Waiting List
Production Schedule
Collapse Menus
Help
 
Live Chat
Customer Support
WalkThru Tutorials
Troubleshooting
FAQs
TechHelp
Consulting Services
About
 
Background
Testimonials
Jobs
Affiliate Program
Richard Rost
Free Lessons
Mailing List
Order
 
Video Tutorials
Handbooks
MYOLP Memberships
Learning Connection
Idiot's Guide to Excel
Volume Discounts
Payment Info
Shipping
Terms of Sale
Contact
 
Live Chat
General Info
Support Policy
Contact Form
Email Richard
Mailing Address
Phone Number
Fax Number
Course Survey
Facebook    Twitter

YouTube Channel    LinkedIn

Blog RSS Feed   
Keywords: microsoft access forum  PermaLink